<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article#" class="no-js">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<link rel="publisher" type="text/html" title="Rockland County Times" href="https://plus.google.com/109114046922017986674" />
	<link rel="pingback" href="https://www.rocklandtimes.com/xmlrpc.php"><title>Reader Can&#039;t Believe Democrats&#039; Amendments to Rockland County 2019 Budget | The Rockland County Times</title>

<!-- All in One SEO Pack 2.10 by Michael Torbert of Semper Fi Web Designob_start_detected [-1,-1] -->

<meta name="keywords"  content="democrats,letter to editor,sloasburg,editorials" />

<link rel="canonical" href="https://www.rocklandtimes.com/2018/12/06/reader-cant-believe-democrats-amendments-to-rockland-county-2019-budget/" />
<!-- /all in one seo pack -->
<link rel="dns-prefetch" href="//connect.facebook.net">
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//connect.facebook.net' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Rockland County Times &raquo; Feed" href="https://www.rocklandtimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Rockland County Times &raquo; Comments Feed" href="https://www.rocklandtimes.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Rockland County Times &raquo; Reader Can’t Believe Democrats’ Amendments to Rockland County 2019 Budget Comments Feed" href="https://www.rocklandtimes.com/2018/12/06/reader-cant-believe-democrats-amendments-to-rockland-county-2019-budget/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.3.2 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.3.2';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-8677906-2';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-8677906-2', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.rocklandtimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='dashicons-css'  href='https://www.rocklandtimes.com/wp-includes/css/dashicons.min.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='wunderground-css'  href='https://www.rocklandtimes.com/wp-content/plugins/wunderground/assets/css/wunderground.css?ver=2.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpa-style-css'  href='https://www.rocklandtimes.com/wp-content/plugins/wp-accessibility/css/wpa-style.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='gabfire-style-css'  href='https://www.rocklandtimes.com/wp-content/themes/advanced-newspaper/style.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.rocklandtimes.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.8.1' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://www.rocklandtimes.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.rocklandtimes.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.rocklandtimes.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.rocklandtimes.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.rocklandtimes.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.rocklandtimes.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.rocklandtimes.com/wp-includes/js/wp-a11y.min.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.rocklandtimes.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WuWidget = {"apiKey":"3ffab52910ec1a0e","_wpnonce":"a25a443f47","ajaxurl":"https:\/\/www.rocklandtimes.com\/wp-admin\/admin-ajax.php","is_admin":"","subdomain":"www"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.rocklandtimes.com/wp-content/plugins/wunderground/assets/js/widget.min.js?ver=2.1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"https:\/\/www.rocklandtimes.com","track_download_as":"event","internal_label":"int","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.rocklandtimes.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.3.2'></script>
<script type='text/javascript' src='https://www.rocklandtimes.com/wp-content/themes/advanced-newspaper/inc/js/jquery.cycle2.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.rocklandtimes.com/wp-content/themes/advanced-newspaper/inc/js/theia-sticky-sidebar.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.rocklandtimes.com/wp-content/themes/advanced-newspaper/inc/js/owl.carousel.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.rocklandtimes.com/wp-content/themes/advanced-newspaper/framework/bootstrap/js/bootstrap.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.rocklandtimes.com/wp-content/themes/advanced-newspaper/inc/js/responsive-menu.js?ver=4.9.8'></script>
<link rel='https://api.w.org/' href='https://www.rocklandtimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rocklandtimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rocklandtimes.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='“New York Is A Nationality” Clothing Brand Founded in Rockland Quickly Gains Attention' href='https://www.rocklandtimes.com/2018/12/06/new-york-is-a-nationality-clothing-brand-founded-in-rockland-quickly-gains-attention/' />
<link rel='next' title='Suffern Family Loses Home &#038; Pets in Massive Fire' href='https://www.rocklandtimes.com/2018/12/06/suffern-family-loses-home-pets-in-massive-fire/' />
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://wp.me/p2hcKS-eaO' />
<link rel="alternate" type="application/json+oembed" href="https://www.rocklandtimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rocklandtimes.com%2F2018%2F12%2F06%2Freader-cant-believe-democrats-amendments-to-rockland-county-2019-budget%2F" />
<meta property="og:title" name="og:title" content="Reader Can’t Believe Democrats’ Amendments to Rockland County 2019 Budget" />
<meta property="og:type" name="og:type" content="article" />
<meta property="og:url" name="og:url" content="https://www.rocklandtimes.com/2018/12/06/reader-cant-believe-democrats-amendments-to-rockland-county-2019-budget/" />
<meta property="og:description" name="og:description" content="To the Editor, I just cant believe Democrats on the County Legislature are intentionally submitting a budget balanced on unrealistic sales tax revenues. The Democrats on our legislature are one of two things 1.Grossly incompetent or 2. Unbelievably Stupid. This same [mistake] of balancing the budget with unrealistic made up numbers has been going on [...]" />
<meta property="og:locale" name="og:locale" content="en_US" />
<meta property="og:site_name" name="og:site_name" content="The Rockland County Times" />
<meta property="twitter:card" name="twitter:card" content="summary" />
<meta property="article:tag" name="article:tag" content="democrats" />
<meta property="article:tag" name="article:tag" content="letter to editor" />
<meta property="article:tag" name="article:tag" content="sloasburg" />
<meta property="article:section" name="article:section" content="Editorials" />
<meta property="article:published_time" name="article:published_time" content="2018-12-06T00:02:45+00:00" />
<meta property="article:modified_time" name="article:modified_time" content="2018-12-07T16:54:12+00:00" />
<meta property="article:author" name="article:author" content="https://www.rocklandtimes.com/author/rctadmin/" />
<meta name="dcterms.coverage" content="World" />
<meta name="dcterms.creator" content=", " />
<meta name="dcterms.date" content="2018-12-06T00:02:45+00:00" />
<meta name="dcterms.identifier" content="https://www.rocklandtimes.com/2018/12/06/reader-cant-believe-democrats-amendments-to-rockland-county-2019-budget/" />
<meta name="dcterms.language" content="en-US" />
<meta name="dcterms.publisher" content="The Rockland County Times" />
<meta name="dcterms.subject" content="Editorials, democrats, letter to editor, sloasburg" />
<meta name="dcterms.title" content="Reader Can’t Believe Democrats’ Amendments to Rockland County 2019 Budget" />
<meta name="dcterms.type" content="Text" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="shortcut icon" href="https://www.rocklandtimes.com/wp-content/themes/advanced-newspaper/framework/admin/images/favicon.ico" /><!-- Custom Styling -->
<style type="text/css">
@media (max-width: 620px) {
  #primary-mid #image-vertical-reel-scroll-slideshow img {
    display: block!important;
  }
}
@media (max-width: 520px) {
  #primary-mid #image-vertical-reel-scroll-slideshow img {
    display: block!important;
  }
}

.theiaStickySidebar {
position:static !important;
position:static; !important;
}</style>
			<script type='text/javascript'>
			(function($) {
				$(document).ready(function() { 
					$(".children").parent("li").addClass("has-child-menu");
					$(".sub-menu").parent("li").addClass("has-child-menu");
					$(".drop").parent("li").addClass("has-child-menu");
					
					$('.fadeimage').hover(
						function() {$(this).stop().animate({ opacity: 0.5 }, 800);},
						function() {$(this).stop().animate({ opacity: 1.0 }, 800);}
					);
					
					$('.mastheadnav li ul,.mainnav li ul,.subnav li ul,.mastheadnav li ul,.mainnav li ul').hide().removeClass('fallback');
					$('.mastheadnav > li,.mainnav > li,.subnav > li,.mainnav > li').hover(
						function () {
							$('ul', this).stop().slideDown(250);
						},
						function () {
							$('ul', this).stop().slideUp(250);
						}
					);

					$('[data-toggle="tooltip"]').tooltip({
						'placement': 'top'
					});	

					$('.sidebar-wrapper, .post-wrapper')
					.theiaStickySidebar({
						additionalMarginTop: 30,
						additionalMarginBottom: 30
					});
				
					/* InnerPage Slider */
					var innerslider = $(".carousel-gallery");
					innerslider.owlCarousel({
					  autoPlay: 999999,
					  pagination:true,
					  singleItem : true,
					  autoHeight : true,
					  mouseDrag: false,
					  touchDrag: false					  
					});	
					$(".carousel-gallery-next").click(function(){
						innerslider.trigger('owl.next');
					});
					$(".carousel-gallery-prev").click(function(){
						innerslider.trigger('owl.prev');
					});
					
					/* InnerPage Slider */
					var owl4 = $(".carousel-four");
					owl4.owlCarousel({
					  autoPlay: 999999,
					  pagination:true,
					  singleItem : true,
					  autoHeight : true,
					  mouseDrag: false,
					  touchDrag: false					  
					});	
					$(".carousel-four-next").click(function(){
						owl4.trigger('owl.next');
					});
					$(".carousel-four-prev").click(function(){
						owl4.trigger('owl.prev');
					});						
					
					// Responsive Menu (TinyNav)
					$(".responsive_menu").tinyNav({
						active: 'current_page_item', // Set the "active" class for default menu
						label: ''
					});
					$(".tinynav").selectbox();			
					
					$('a[href="#top"]').click(function(){
						$('html, body').animate({scrollTop:0}, 'slow');
						return false;
					});
				});
			})(jQuery);
			</script>
		<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><meta property="og:site_name" content="The Rockland County Times">
<meta property="og:type" content="article">
<meta property="og:locale" content="en_US">
<meta property="fb:app_id" content="628346180581132">
<meta property="og:url" content="https://www.rocklandtimes.com/2018/12/06/reader-cant-believe-democrats-amendments-to-rockland-county-2019-budget/">
<meta property="og:title" content="Reader Can’t Believe Democrats’ Amendments to Rockland County 2019 Budget">
<meta property="og:description" content="To the Editor, I just cant believe Democrats on the County Legislature are intentionally submitting a budget balanced on unrealistic sales tax revenues. The Democrats on our legislature are one of two things 1.Grossly incompetent or 2. Unbelievably Stupid. This same [mistake] of balancing the budget with unrealistic made up numbers has been going on&hellip;">
<meta property="article:published_time" content="2018-12-06T05:02:45+00:00">
<meta property="article:modified_time" content="2018-12-07T21:54:12+00:00">
<meta property="article:author" content="https://www.rocklandtimes.com/author/rctadmin/">
<meta property="article:section" content="Editorials">
<meta property="article:tag" content="democrats">
<meta property="article:tag" content="letter to editor">
<meta property="article:tag" content="sloasburg">
<style type="text/css" media="screen"></style></head>

<body data-rsssl=1 class="post-template-default single single-post postid-54486 single-format-standard body-default" itemscope="itemscope" itemtype="http://schema.org/WebPage">


<div class="container">

	<header itemscope="itemscope" itemtype="http://schema.org/WPHeader" role="banner">
		<div class="row"><!-- Site Masthead Row-->
			<nav class="col-md-12 masthead-navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement" role="navigation">
				<ul class="mastheadnav">
					
					<li><span class="arrow-right"></span></li>
					<li id="menu-item-45082" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-45082"><a href="https://www.rocklandtimes.com/home/">Home</a></li>
<li id="menu-item-45083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45083"><a href="https://www.rocklandtimes.com/category/breaking-news/">Breaking News</a></li>
<li id="menu-item-45084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45084"><a href="https://www.rocklandtimes.com/category/local/">Local</a></li>
<li id="menu-item-45085" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45085"><a href="https://www.rocklandtimes.com/category/politics/">Politics</a></li>
					 
											<li class="pull-right social_header">
															<a class="socialsite-facebook" href="http://www.facebook.com/mostlocalnews/" title="Facebook" rel="nofollow"><span>Friend on Facebook</span>
									<i class="fa fa-facebook pull-left"></i>
								</a>
							
															<a class="socialsite-twitter" href="http://twitter.com/Rockland_News" title="Twitter" rel="nofollow"><span>Follow on Twitter</span>
									<i class="fa fa-twitter pull-left"></i>
								</a>
							
															<a class="socialsite-google" href="https://plus.google.com/109114046922017986674" title="Google+" rel="nofollow"><span>Add to Google+ Circle</span>
									<i class="fa fa-google-plus pull-left"></i>
								</a>
							
							
														
														
							
														
								

															

							<a class="socialsite-rss" href="https://www.rocklandtimes.com/feed/" title="Site feed" rel="nofollow">
								<span>Subscribe to RSS</span> <i class="fa fa-rss pull-left"></i>
							</a>
						</li>
											
					
					<li class="pull-right gab_headersearch"> <a data-toggle="modal" href="#searchModal"><i class="fa fa-search"></i> Search</a></li>
					<li class="pull-right"></li>
				</ul>
			</nav>

			<!-- Modal -->
<div class="modal fade" id="searchModal" tabindex="-1" role="dialog" aria-labelledby="myModalLabel" aria-hidden="true">
	<div class="modal-dialog">
	  <div class="modal-content">
		<div class="modal-header">
		  <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
		  <h4 class="modal-title">Search in Site</h4>
		</div>
		<div class="modal-body">
			<form action="https://www.rocklandtimes.com/">
				<div class="input-prepend">
					<label>To search in site, type your keyword and hit enter</label>
					<input type="text" name="s" class="form-control" placeholder="Type keyword and hit enter">
				</div>
			</form>	
		</div>
		<div class="modal-footer">
		  <button type="button" class="btn btn-default" data-dismiss="modal">Close</button>
		</div>
	  </div><!-- /.modal-content -->
	</div><!-- /.modal-dialog -->
</div><!-- /.modal -->		</div><!-- /.row Site Masthead Row -->
	
		<div class="row">
			<div class="col-lg-12">
				<div id="header">
											<a href="https://www.rocklandtimes.com/" title="Rockland County&#039;s Source for Real News Since 1888">
							<img src="https://www.rocklandtimes.com/wp-content/uploads/2018/11/Screen-Shot-2018-11-03-at-8.28.58-PM.png" id="header_banner" alt="The Rockland County Times" title="The Rockland County Times"/>
						</a>
											

				</div><!-- /header -->	
			</div><!-- /col-lg-12 -->	
		</div><!-- /row -->	
		
		<div class="row site-nav">
			<div class="col-lg-12">
				
				<nav class="main-navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement" role="navigation">
					<ul class="mainnav responsive_menu">
						<li><a href="https://www.rocklandtimes.com/">HOME</a></li>
						<li id="menu-item-178" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-178"><a href="https://www.rocklandtimes.com/category/breaking-news/">Breaking News</a></li>
<li id="menu-item-179" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-179"><a href="https://www.rocklandtimes.com/category/local/">Local</a></li>
<li id="menu-item-180" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-180"><a href="https://www.rocklandtimes.com/category/politics/">Politics</a></li>
<li id="menu-item-181" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181"><a href="https://www.rocklandtimes.com/category/sports/">Sports</a></li>
<li id="menu-item-182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-182"><a href="https://www.rocklandtimes.com/category/entertainment/">Lifestyle &#038; Entertainment</a></li>
<li id="menu-item-177" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-177"><a href="https://www.rocklandtimes.com/category/editorials/">Editorials</a></li>
<li id="menu-item-45071" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-45071"><a href="https://www.rocklandtimes.com/subscribe/">Subscribe</a></li>
					</ul>
				</nav>
				
				<nav class="secondary-navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement" role="navigation">
					<ul class="subnav responsive_menu">
						<li id="menu-item-170" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-170"><a href="https://www.rocklandtimes.com/about/">About</a></li>
<li id="menu-item-39248" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39248"><a href="https://www.rocklandtimes.com/category/featured-news/">Featured News</a></li>
<li id="menu-item-200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-200"><a href="https://www.rocklandtimes.com/archives-2/">Archives</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.rocklandtimes.com/contact/">Contact</a></li>
<li id="menu-item-153" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-153"><a href="https://www.rocklandtimes.com/find_us/">Where to Buy</a></li>
<li id="menu-item-188" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188"><a href="https://www.rocklandtimes.com/media-kit/">Advertise</a></li>
<li id="menu-item-210" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-210"><a href="https://www.rocklandtimes.com/subscribe/">Subscribe</a></li>
	
					</ul>
				</nav>				
				
			</div>
		</div>	
	</header>
	
	<div class="row default">
	
				
		<main class="col-xs-12 col-md-8 col-sm-8 post-wrapper" role="main" itemprop="mainContentOfPage" itemscope="itemscope" itemtype="http://schema.org/Blog">

							<div class="row">
					<div class="col-lg-12 col-md-12">
						<div class="post-lead">
							<h1 class="entry-title single-post-title" itemprop="headline">
								Reader Can’t Believe Democrats’ Amendments to Rockland County 2019 Budget							</h1>
							
							<p class="postmeta"><span class="gabfire_meta gabfiremeta_bydate">By <span class="author vcard" itemscope="itemscope" itemtype="http://schema.org/Person" itemprop="author"><a href="https://www.rocklandtimes.com/author/rctadmin/" rel="author" class="fn" itemprop="name">rctadmin</a></span> on <time class="published updated" itemprop="datePublished" datetime="December 6, 2018T12:02 am">December 6, 2018</time></span><span class="gabfire_meta gabfiremeta_comment"><a href="https://www.rocklandtimes.com/2018/12/06/reader-cant-believe-democrats-amendments-to-rockland-county-2019-budget/#respond"><fb:comments-count xmlns="http://ogp.me/ns/fb#" href="https://www.rocklandtimes.com/2018/12/06/reader-cant-believe-democrats-amendments-to-rockland-county-2019-budget/"></fb:comments-count> Comments</a></span></p>						</div>		
					</div>
				</div>			
						
				
		<section class="article-wrapper">
		
						
				<article itemscope itemtype="http://schema.org/NewsArticle" class="entry post-54486 post type-post status-publish format-standard hentry category-editorials tag-democrats tag-letter-to-editor tag-sloasburg last_archivepost">
										
								
							<div class="social-sharethis-post">
										
				
					<a href="http://www.facebook.com/sharer.php?u=https://www.rocklandtimes.com/2018/12/06/reader-cant-believe-democrats-amendments-to-rockland-county-2019-budget/&t=Reader Can’t Believe Democrats’ Amendments to Rockland County 2019 Budget" data-toggle="tooltip" title="Share on Facebook" rel="nofollow"><span>Share on Facebook</span>
						<i class="fa fa-facebook pull-left"></i>
					</a>

					<a href="http://twitter.com/home?status=Reader Can’t Believe Democrats’ Amendments to Rockland County 2019 Budget => https://www.rocklandtimes.com/2018/12/06/reader-cant-believe-democrats-amendments-to-rockland-county-2019-budget/" data-toggle="tooltip" title="Share on Twitter" rel="nofollow"><span>Follow on Facebook</span>
						<i class="fa fa-twitter pull-left"></i>
					</a>

					<a href="https://plus.google.com/share?url=https://www.rocklandtimes.com/2018/12/06/reader-cant-believe-democrats-amendments-to-rockland-county-2019-budget/" data-toggle="tooltip" title="Share on Google+" rel="nofollow"><span>Add to Google+</span>
						<i class="fa fa-google-plus pull-left"></i>
					</a>

					<a href="http://www.linkedin.com/shareArticle?mini=true&url=https://www.rocklandtimes.com/2018/12/06/reader-cant-believe-democrats-amendments-to-rockland-county-2019-budget/&title=Reader Can’t Believe Democrats’ Amendments to Rockland County 2019 Budget&summary=&source=The Rockland County Times" data-toggle="tooltip" title="Share on LinkedIn" rel="nofollow"><span>Connect on Linked in</span>
						<i class="fa fa-linkedin pull-left"></i>
					</a>

					<a class="pull-right" href="mailto:?mailto:?subject=The%20Rockland%20County%20Times%20%3A%20&amp;body=I%20recommend%20this%20page%3A%20.%0AYou%20can%20read%20it%20on%3A%20https%3A%2F%2Fwww.rocklandtimes.com%2F2018%2F12%2F06%2Freader-cant-believe-democrats-amendments-to-rockland-county-2019-budget%2F" data-toggle="tooltip" title="Send by Email" rel="nofollow"><span>Subscribe by Email</span>
						<i class="fa fa-envelope-o pull-left"></i>
					</a>
					
					<a class="pull-right" href="javascript:window.print()" data-toggle="tooltip" title="Print This Post" rel="nofollow"><span>Print This Post</span>
						<i class="fa fa-print pull-left"></i>
					</a>
				</div>	
				<div class="clearfix"></div>
			<div class="entry-content" itemprop="text">
<div class="fb-social-plugin fb-send" data-font="arial" data-ref="above-post" data-href="https://www.rocklandtimes.com/2018/12/06/reader-cant-believe-democrats-amendments-to-rockland-county-2019-budget/"></div>

<div class="fb-social-plugin fb-like" data-font="arial" data-ref="above-post" data-href="https://www.rocklandtimes.com/2018/12/06/reader-cant-believe-democrats-amendments-to-rockland-county-2019-budget/" data-layout="button_count" data-share="true" data-width="450"></div>
<p>To the Editor,</p>
<p>I just cant believe Democrats on the County Legislature are intentionally submitting a budget balanced on unrealistic sales tax revenues. The Democrats on our legislature are one of two things 1.Grossly incompetent or 2. Unbelievably Stupid. This same [mistake] of balancing the budget with unrealistic made up numbers has been going on for years in Rockland County, It resulted in the County falling into Debt. The People of Rockland County deserve better. It appears some of these Legislators just don&#8217;t care to do their job in a correct and competent way. Perhaps they should be IMPEACHED for their incompetence.</p>
<p>Sincerely,<br />
Dave Veraja<br />
Sloatsburg</p>
<p class="posttags"><i class="fa fa-tags"></i>&nbsp;&nbsp;<a href="https://www.rocklandtimes.com/tag/democrats/" rel="tag">democrats</a>, <a href="https://www.rocklandtimes.com/tag/letter-to-editor/" rel="tag">letter to editor</a>, <a href="https://www.rocklandtimes.com/tag/sloasburg/" rel="tag">sloasburg</a></p>
<div class="single_postmeta">
<p><img alt='' src='https://secure.gravatar.com/avatar/da3fef8ff261486603726f05685147e8?s=35&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/da3fef8ff261486603726f05685147e8?s=70&#038;d=mm&#038;r=g 2x' class='avatar avatar-35 photo' height='35' width='35' /></p>
<p><strong class="entry-title">Reader Can’t Believe Democrats’ Amendments to Rockland County 2019 Budget</strong> added by <a href="https://www.rocklandtimes.com/author/rctadmin/" rel="author" class="author vcard"><span class="fn">rctadmin</span></a> on <time class="published updated" itemprop="datePublished" datetime="2018-12-06T00:02">December 6, 2018</time><br /><a class="block" href="https://www.rocklandtimes.com/author/rctadmin/">View all posts by rctadmin &rarr;</a></p>
</div>

<div class="fb-social-plugin fb-like" data-font="arial" data-ref="below-post" data-href="https://www.rocklandtimes.com/2018/12/06/reader-cant-believe-democrats-amendments-to-rockland-county-2019-budget/" data-layout="button_count" data-share="true" data-width="450"></div>

<div class="fb-social-plugin fb-send" data-font="arial" data-ref="below-post" data-href="https://www.rocklandtimes.com/2018/12/06/reader-cant-believe-democrats-amendments-to-rockland-county-2019-budget/"></div>
</div>					<meta content="2018-12-06T00:02" itemprop="datePublished">
				</article>
				
			
			
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<div class="fb-social-plugin comment-form fb-comments" id="commentform" data-href="https://www.rocklandtimes.com/2018/12/06/reader-cant-believe-democrats-amendments-to-rockland-county-2019-budget/" data-width="470" data-order-by="social"></div>
</div></div>
				
		</section><!-- articles-wrapper -->			
		</main><!-- col-md-8 -->
		
		<div class="col-md-4 col-sm-4 col-xs-12 sidebar-wrapper">
	<div class="theiaStickySidebar">
		<div class="sidebar" role="complementary" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
			<aside id="text-22" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><iframe src='https://www.admaker247.com/show/94f15367793f242059659e632785db9577f8d7bf' width='300' height='170' style='border:0;'></iframe>
<iframe 
 src='https://www.admaker247.com/show/5edcebac8f8737911e851e6ddc098e48f3577e2a' width='300' height='170' style='border:0;'></iframe>
<iframe src='https://www.admaker247.com/show/f185dcd4d260e99141fbf062a536d1e40b5f8c2d' width='300' height='170' style='border:0;'></iframe>
<iframe src="https://services.zoomlean.com/api/content_discovery_widget/frame/20c8dd89c5ad9da694ec874038bb34" style="margin:0 auto;border:1px solid #eee;" scrolling="no"></iframe></div>
		</div></aside>
		</div>
	</div>	
</div>	</div>	
	
	<footer role="contentinfo" itemscope="itemscope" itemtype="http://schema.org/WPFooter">

		<div class="row footercats">
			<div class="col-md-12">
				<ul itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement" role="navigation">
					<div class="menu"><ul>
<li class="page_item page-item-14714"><a href="https://www.rocklandtimes.com/home/">Home</a></li>
<li class="page_item page-item-168"><a href="https://www.rocklandtimes.com/about/">About</a></li>
<li class="page_item page-item-195"><a href="https://www.rocklandtimes.com/archives-2/">Archives</a></li>
<li class="page_item page-item-186"><a href="https://www.rocklandtimes.com/media-kit/">Media Kit</a></li>
<li class="page_item page-item-197"><a href="https://www.rocklandtimes.com/site-map/">Site Map</a></li>
<li class="page_item page-item-207"><a href="https://www.rocklandtimes.com/subscribe/">Subscribe</a></li>
<li class="page_item page-item-6904"><a href="https://www.rocklandtimes.com/thank-you-for-donating/">Thank You for Donating</a></li>
<li class="page_item page-item-213"><a href="https://www.rocklandtimes.com/thank-you-for-ordering-born-minus/">Thank you for ordering Born Minus</a></li>
<li class="page_item page-item-205"><a href="https://www.rocklandtimes.com/thank-you/">Thank You!!!</a></li>
<li class="page_item page-item-7 page_item_has_children"><a href="https://www.rocklandtimes.com/find_us/">Where to Buy</a>
<ul class='children'>
	<li class="page_item page-item-9"><a href="https://www.rocklandtimes.com/find_us/locations/">Locations</a></li>
</ul>
</li>
<li class="page_item page-item-6"><a href="https://www.rocklandtimes.com/contact/">Contact</a></li>
<li class="page_item page-item-145"><a href="https://www.rocklandtimes.com/born-minus-from-shoeshine-boy-to-news-publisher-an-italian-american-journey/">Born Minus Book</a></li>
<li class="page_item page-item-5"><a href="https://www.rocklandtimes.com/blog/">Blog</a></li>
</ul></div>
	
				</ul>
			</div>
		</div>
			
		<div class="footer-firstrow row">
		
			<div class="col-md-4 col-lg-4 col-sm-3 col-xs-12 footer-firstrow-widget">
							</div>
			
			<div class="col-md-4 col-lg-4 col-sm-4 col-xs-12 footer-firstrow-widget footer-mid-column">
				<aside id="text-17" class="widget widget_text"><div class="widgetinner"><h3 class="widgettitle">Visit Us On Facebook</h3>
			<div class="textwidget"><div class="fb-like-box" data-href="https://www.facebook.com/mostlocalnews" data-colorscheme="light" data-show-faces="false" data-header="true" data-stream="false" data-show-border="true"></div></div>
		</div></aside>
<aside id="text-16" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><div class="fb-facepile" data-href="https://www.facebook.com/mostlocalnews" data-max-rows="1" data-colorscheme="light" data-size="medium" data-show-count="true"></div></div>
		</div></aside>
<aside id="text-26" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><script type='text/javascript'>window._zlean = { user_id: (window.user_email || window.user_id || null), user_value: (window.visitor_value || null) };</script>
<script src='https://services.zoomlean.com/static/remote.js?api_key=20c8dd89c5ad9da694ec874038bb34' type='text/javascript' async></script></div>
		</div></aside>
			</div>
			
			<div class="col-md-4 col-lg-4 col-sm-5 col-xs-12 footer-firstrow-widget">
							</div>
			
		</div>
	<div class="row footer-meta-wrapper">
		<div class="col-md-12">
			<div class="footer-meta">
			
				<div class="footer-metaleft pull-left">
					© 2017 Citizen Publishing Corporation of Rockland. 
All Rights Reserved. 
119 Main Street, Nanuet, NY 10954 
Phone: (845) 627 1414 | Fax: (845) 627 1411				</div><!-- #site-info -->
							
				<div class="footer-metaleft pull-right">
					<a href="https://www.rocklandtimes.com/wp-login.php">Log in</a> - 			
										<a href="http://wordpress.org/" title="Semantic Personal Publishing Platform" rel="generator">Powered by WordPress</a> - 
					<a href="http://www.gabfirethemes.com/" title="WordPress Newspaper Themes">Gabfire Themes</a> 
						<div style="display:none">
	<div class="grofile-hash-map-da3fef8ff261486603726f05685147e8">
	</div>
	</div>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201849'></script>
<script type='text/javascript' src='https://www.rocklandtimes.com/wp-content/plugins/wp-accessibility/js/longdesc.button.js?ver=1.0'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2018Decaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.rocklandtimes.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.rocklandtimes.com/wp-includes/js/comment-reply.min.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"xfbml":true,"appId":"628346180581132"});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}}
/* ]]> */
</script>
<script type="text/javascript">(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)){return}js=d.createElement(s);js.id=id;js.src="https:\/\/connect.facebook.net\/en_US\/all.js";fjs.parentNode.insertBefore(js,fjs)}(document,"script","facebook-jssdk"));</script>
<script type='text/javascript' src='https://www.rocklandtimes.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<div id="fb-root"></div>
<script type='text/javascript'>
//<![CDATA[
(function( $ ) { 'use strict';
	
	$('a').removeAttr('target');
	
	$('input,a,select,textarea,button').removeAttr('tabindex');
	
}(jQuery));
//]]>
</script><script type='text/javascript' src='https://stats.wp.com/e-201849.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.8.1',blog:'33653282',post:'54486',tz:'-5',srv:'www.rocklandtimes.com'} ]);
	_stq.push([ 'clickTrackerInit', '33653282', '54486' ]);
</script>
				</div> <!-- #footer-right-side -->
			</div>
		</div>
	</div>
		
	</footer><!-- /footer -->
	
</div><!-- /container -->
</body>
</html>